Ubuntu

Ubuntu, finally!!!

Finally got 3d acceleration working on Ubuntu, I used 13.10!!! Clean install it worked!!! Finally!!! ๐Ÿ™‚

System Info says Graphics driver is Gallium 0.4 on AMD PITCAIRN. My system specs again:

i7-3930K
Asus Rampage IV Formula
8GB RAM
2GB Radeon HD 7850
Several hard drives

Ubuntu

Ubuntu!

I was getting tired of running Ubuntu on a virtual machine so I decided to dual boot my PC. I picked Ubuntu 12.04 LTS because that would have better support for hardware, I was concerned whether my graphics card would not work properly. Here are my system specs:

i7-3930K
Asus Rampage IV Formula
8GB RAM
2GB Radeon HD 7850
Several hard drives

Here are the problems I encountered:

1) BIOS/UEFI: I had heard of UEFI before but I didn’t know what it was. Anyways, my first mistake was trying to install Ubuntu in UEFI mode when my Windows 7 was in BIOS mode. Follow thisย https://help.ubuntu.com/community/UEFI to see if your Windows is in UEFI or BIOS mode. Once I changed my BIOS settings to boot only in BIOS mode, things started working as expected.

2) Partitioning: I don’t know why I got this wrong so many times, anyways, when installing Ubuntu, partition it yourself:

(assuming you have a 1TB hard drive)
200-300MB    /boot
300MB-960GB  /
30GB         swap

Make sure you select /boot partition correctly in the bootloader dropdown.

3) Graphics Card: Long story short, install the drivers suggested by Ubuntu through the additional drivers window. Ignore the fact that it still says “Unknown” graphics in the System Details window. If you have dual screens like me and want an extended desktop, the Ubuntu Displays menu didn’t allow it so use Catalyst Control Center to do it (gksudo amdcccle). I think I also read somewhere that it also helped that I ran Ubuntu in BIOS mode and UEFI mode.

So I ended doing the whole thing about 10 times, yes yes I know I’m such a n00b but but but it works now ๐Ÿ™‚